Arduino esp8266



  • Beste TU Delft,

    voor ons PWS werken we aan een soort verkenningsrobot die zelfstandig kan rijden en zelf meetingen uitvoert doormiddel van sensoren, deze metingen worden vervolgens via een wifi sensor naar een website verzonden, namelijk Thingspeak. De sensoren die we gebruiken zijn: DHT 11 (temp. + luchtvochtigheidsensor), BMP180 (barometer), LDR en een ultrasone afstandsensor zodat het obstakels kan ontwijken. Voor het verzenden van deze gegevens gebruiken we de ESP8266 wifi sensor, helaas lopen we met deze sensor vast, bij het uploaden en verzenden, het compileren daarentegen lukt wel. We gebruiken een arduino Uno board, maar we krijgen telkens tijdens het uploaden de foutmelding:
    warning: espcomm_sync failed
    error: espcomm_open failed
    Soms lukt het uploaden wel, maar dan lukt het niet om de gegevens te verzenden, maar als we dan weer uploaden krijgen we de bovenstaande foutmelding.
    Voor de aansluiting hebben we de ESP8266 direct aangesloten op de 3.3v van de arduino maar het lukt niet om de gegevens te versturen. Heeft u misschien ideeën of tips hoe we dit kunnen oplossen?

    Met vriendelijke groeten,
    Sabrina& Kevin



  • Hoi Sabrina en Kevin,

    Het is erg lastig om dit soort problemen op afstand op te lossen, maar ik ga mijn best doen.

    Alleerst even een aantal vragen wat betreft jullie probleem:

    1. jullie kunnen je code dus wel compileren, maar niet uploaden naar de arduino?
    2. hebben jullie alle sensoren aangesloten, of alleen de wifi temperatuur sensor?
    3. Wat voor programma proberen jullie precies te uploaden? (wellicht is het handig de code te sturen naar info@scholierenlab.nl, zet er even bij dat het voor mij (Matthijs) bedoeld is)

    Met wat meer info kan ik jullie beter helpen, maar het volgende kan ik in ieder geval adviseren:

    1. Probeer de wifi sensor in de meest simpele opstelling aan de praat te krijgen. Een goede handleiding kun je hier of hier vinden.
    2. Veel websites zeggen dat de 3.3v aansluiting niet genoeg vermogen (stroom) kan leveren voor de sensor. Probeer het met een externe power supply.
    3. Bekijk dit forum even. Dit gaat precies over jullie foutmelding. Misschien staat er wat nuttigs op.

    Ik hoop dat dit helpt!

    Groeten,
    Matthijs


Aanmelden om te reageren
 

Het lijkt erop dat je verbinding naar Forum verloren is gegaan, wacht even terwijl we de verbinding proberen te herstellen.